GoogleAnalyticsVisits (2)

エラーメッセージが syntax error, unexpected ‘}‘ であれば、多くの例を Google 先生が教えてくれる。

しかし { となると、4 ページくらい進んでやっと facebook 関連フォーラム を見つけた。 そこには

  1. 1st check that you can run php5 on ur server.
  2. 2nd get into note pad and make a file with this one line in it: AddType x-mapp-php5 .php
  3. 3rd save the file as htaccess.txt
  4. 4th upload this file to your root directory on your server and rename the file to .htaccess
  5. 5th it will be a hiden file so confi your ftp so it shows the file if needed.
  6. 6th now run your facebook application.

となっていてナント単純な話ではなさそう。

そこでインストールしてphp のバージョンを調べても 5.2.6 となっているのにと思いながら、lolipop と php について検索すると、古い記事ばかりなので大して当てにならないと考え、サーバーに照会のメールを送る。

一方で質問板に質問をした。 やがて回答がつき、「php は 5 でないのかも」。

暫くすると、別の回答がつき、「そんな try の部分でエラーになる場合は、サーバーの php のバージョンが4の可能性がありますね。」と。

lolipop から返信があり、それには「php4 からの php5 切り替えツールを用意してある」とのことで、WordPress 以外 php を使うつもりもないので、php5 にした。

lolipop ftp は普段 fireFTP を使うんで、そんなの全く目に入って無かった。 面目ない。 パーミッションの変更とか、.htaccess の編集くらいしか用がないんだもの。

切り替えて間もなく再チャレンジ。 エーーーッ、まだエラー ?
即時には反映されないのかも知れない。

かなりの時間を置いてまた、有効化にチャレンジ。
できたあああ。パチパチパチ。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*

code